Commit 2a001436 authored by Anis Kacem's avatar Anis Kacem
Browse files

update documentation, instructions, routines

parent 7c9c31ed
sharp_cvi2_artec3d.egg-info
sharp_env
sharp_env/*
*/__pycache__
__pycache__/*
*.pyc
......@@ -9,7 +9,7 @@ Organised by [CVI²](https://cvi2.uni.lu) & [Artec3D](https://www.artec3d.com).
## Overview
We propose three challenges. The task of the challenges is to reconstruct a full 3D textured mesh from a partial 3D scan. The first challenge is for human bodies, while the second and third challenges are for a variety of generic objects. The third challenge launches a new unique dataset.
We propose three challenges. The main goal of the challenges is to reconstruct full 3D meshes from partial/corrupted 3D scans. The first challenge is for human bodies, while the second and third challenges are for a variety of generic objects. The third challenge launches a new unique dataset. The focus of challenge 1/2 is on recovering textured 3D meshes from partial scans. The aim of challenge 3 is to recover feature (sharp) edges in corrupted scans.
- Challenge 1 - Recovery of Human Body Scans:
......@@ -28,4 +28,44 @@ This challenge is focused on recovering feature edges of 3D scans. Here, the ver
## Detailed instructions
To be announced. Stay tuned.
- [Challenge 1: Recovery of Human Body Scans](doc/challenge_1.md)
- [Challenge 2: Recovery of Generic Object Scans](doc/challenge_2.md)
- [Challenge 3: Recovery of Feature Edges in Object Scans](doc/challenge_3.md)
- [Evaluation and metrics](doc/evaluation.md)
- [Datasets](doc/datasets.md)
- [Dataset splits](doc/dataset_splits.md)
- [Data formats](doc/formats.md)
- [Command line interface (CLI)](doc/cli.md)
## Installation
Create virtual environment
```bash
$ python3 -m venv sharp_env
```
Activate your virtual environment
```bash
$ source sharp_env/bin/activate
```
Upgrade pip to the latest version
```bash
$ pip install --upgrade pip
```
Install package in editable mode. All the required dependencies will be installed from setup.
```bash
$ pip install --editable .
```
Alternatively, you can install the required packages from requirements.txt
```bash
$ pip install -r requirements.txt
```
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment